redSHOP Minimum Requirements

As redSHOP is an extension designed to work within the Joomla! Content Management system, the minimum requirements to run both Joomla and redSHOP are as follows: 

For Joomla 2.5, 3.x and  future versions:

PHP:

  • Minimum version required: 5.2.4+ 
  • Recommended versions: 5.3.x+ 
Further information: PHP.Net
(Notes: Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation)

MySQL:

  • Minimum version required: 5.0.4+ 
  • Recommended versions: 5.0.4+ 
Further information: MySQL
(Notes: Joomla is not yet compatible with MySQL 6.x)

Apache:

  • Minimum version required: 2.x+ 
  • Recommended versions: 2.x+ 
Further information: Apache
(Notes: In order to use SEO URLs, you will need to have the Apache mod_rewrite extension installed. )

Microsoft IIS:

  • Minimum version required:
  • Recommended versions:
Further information: IIS
(Notes: )